about summary refs log tree commit diff stats
path: root/nix/default.nix
diff options
context:
space:
mode:
authorAlan Pearce2024-04-21 14:00:47 +0200
committerAlan Pearce2024-04-21 14:00:47 +0200
commita86e275fdbde49b5530f09915a4f3ec3f6d6a308 (patch)
treeb97e395d6785a695be41c57246e684564c6c308e /nix/default.nix
parentc258ad4dfcd394c212073d6bd809de9754c30955 (diff)
downloadwebsite-a86e275fdbde49b5530f09915a4f3ec3f6d6a308.tar.lz
website-a86e275fdbde49b5530f09915a4f3ec3f6d6a308.tar.zst
website-a86e275fdbde49b5530f09915a4f3ec3f6d6a308.zip
move server code to cmd/server
Diffstat (limited to 'nix/default.nix')
-rw-r--r--nix/default.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/nix/default.nix b/nix/default.nix
index 4299676..32c546f 100644
--- a/nix/default.nix
+++ b/nix/default.nix
@@ -14,7 +14,7 @@ let
         public
       ];
       config = {
-        Cmd = [ "${server}/bin/website" ];
+        Cmd = [ "${server}/bin/server" ];
         Env = [
           "PRODUCTION=true"
           "LISTEN_ADDRESS=::"
@@ -39,7 +39,7 @@ with pkgs; rec {
       fileset = unions [
         ./../go.mod
         ./../go.sum
-        ./../cmd
+        ./../cmd/build
         ./../internal
       ];
     };
@@ -61,7 +61,7 @@ with pkgs; rec {
     ${builder}/bin/build -s $src -d $out/public
   '';
   server = buildGoApplication {
-    pname = "website";
+    pname = "server";
     inherit version;
     CGO_ENABLED = 0;
     src = with lib.fileset; toSource {
@@ -69,7 +69,7 @@ with pkgs; rec {
       fileset = unions [
         ./../go.mod
         ./../go.sum
-        ./../server.go
+        ./../cmd/server
         ./../internal
       ];
     };