about summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorAlan Pearce2023-05-18 20:52:18 +0200
committerAlan Pearce2023-05-18 20:52:18 +0200
commit397ef49a967738fc0046ea9308f8fd7f1c447613 (patch)
tree513920ee8b4e8a671394ea6eef9c557b22a3c6ae /flake.nix
parent83b0584d636cbfab9a81c03d2455424ddb885d1f (diff)
downloadwebsite-397ef49a967738fc0046ea9308f8fd7f1c447613.tar.lz
website-397ef49a967738fc0046ea9308f8fd7f1c447613.tar.zst
website-397ef49a967738fc0046ea9308f8fd7f1c447613.zip
Make buildable with nix (requires submodule workaround)
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix28
1 files changed, 19 insertions, 9 deletions
diff --git a/flake.nix b/flake.nix
index 7403f7e..6625f73 100644
--- a/flake.nix
+++ b/flake.nix
@@ -9,15 +9,25 @@
         pkgs = nixpkgs.legacyPackages.${system};
       in
       {
-        devShells.default = pkgs.mkShell {
-          packages = with pkgs; [
-            brotli
-            gzip
-            zstd
-            gnugrep
-            git
-            zola
-          ];
+        packages = {
+          default = pkgs.stdenv.mkDerivation {
+            name = "alanpearce.eu";
+            src = self;
+
+            enableParallelBuilding = true;
+            makeFlags = [ "PREFIX=$(out)" ];
+
+            nativeBuildInputs = with pkgs; [
+              zola
+              fd
+              brotli
+              gzip
+              zstd
+              git
+            ];
+
+            dontFixup = true;
+          };
         };
       });
 }