use justfile for scripting
1 file changed, 7 insertions(+), 13 deletions(-)
changed files
M flake.nix → flake.nix
@@ -24,18 +24,17 @@ nativeBuildInputs = with pkgs; [ go ]; packages = import ./nix/default.nix { inherit pkgs self; }; + commonShellPackages = with pkgs; [ + just + skopeo + flyctl + ]; in { inherit packages; devShells = { ci = pkgs.mkShell { - packages = with pkgs; [ - skopeo - flyctl - ] - ++ (import ./nix/scripts.nix { - inherit pkgs; - }); + packages = commonShellPackages; }; default = pkgs.mkShell { inputsFrom = [ packages.builder ];@@ -45,13 +44,8 @@ gotools go-tools gomod2nix.packages.${system}.default gci - skopeo netlify-cli - flyctl - ] - ++ (import ./nix/scripts.nix { - inherit pkgs; - }); + ] ++ commonShellPackages; }; }; });