all repos — website @ cf0da6d13edc55c003564f31d56a659cfa681e0c

My website

remove flake and docker setup

Alan Pearce
commit

cf0da6d13edc55c003564f31d56a659cfa681e0c

parent

f690e8cb7a820b0685b98f83a6761cfc169487e4

1 file changed, 35 insertions(+), 2 deletions(-)

changed files
M shell.nixshell.nix
@@ -1,3 +1,36 @@
-{ system ? builtins.currentSystem }: +{ pkgs ? ( + let + sources = import ./npins; + in + import sources.nixpkgs { + overlays = [ + (import "${sources.gomod2nix}/overlay.nix") + ]; + } + ) +}: +let + goEnv = pkgs.mkGoEnv { pwd = ./.; }; + inherit (import ./.) pre-commit-check; +in +pkgs.mkShell { + inherit (pre-commit-check) shellHook; + packages = with pkgs; [ + goEnv -(builtins.getFlake (toString ./.)).devShells.${system}.default + npins + gopls + gotools + go-tools + gci + hyperlink + systemfd + just + modd + + skopeo + flyctl + nodePackages.vercel + netlify-cli + ]; +}