Use gitlab CI commit 3bca937c9ff91852269a828de0c778db7d1423df Author: Alan Pearce <alan@alanpearce.eu> Date: Sat Apr 20 01:14:26 2024 +0200 create gitlab CI configuration commit ee9eeab17ac88f4020d857dcceb458c66418e2f6 Author: Alan Pearce <alan@alanpearce.eu> Date: Sat Apr 20 16:07:01 2024 +0200 make helpers for both building and streaming docker images commit d8340ec8ff3e3f9c51b55e95e27e518330435b7c Author: Alan Pearce <alan@alanpearce.eu> Date: Sat Apr 20 00:20:34 2024 +0200 use long git hashes for docker tags
1 file changed, 10 insertions(+), 0 deletions(-)
changed files
M flake.nix → flake.nix
@@ -28,6 +28,15 @@ in { inherit packages; devShells = { + ci = pkgs.mkShell { + packages = with pkgs; [ + skopeo + flyctl + ] + ++ (import ./nix/scripts.nix { + inherit pkgs; + }); + }; default = pkgs.mkShell { inputsFrom = [ packages.builder ]; packages = with pkgs; [@@ -36,6 +45,7 @@ gotools go-tools gomod2nix.packages.${system}.default gci + skopeo netlify-cli flyctl ]