all repos — website @ 666ffe8543fc6ef86be384c7f652d80c41935996

My website

Use flakes and `nix develop`

Alan Pearce
commit

666ffe8543fc6ef86be384c7f652d80c41935996

parent

d369605691337a2313a495ffc8db204653177f64

1 file changed, 20 insertions(+), 0 deletions(-)

changed files
A flake.nix
@@ -0,0 +1,20 @@
+{ + description = "My website, alanpearce.eu"; + inputs.nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable"; + inputs.flake-utils.url = "github:numtide/flake-utils"; + + outputs = { self, nixpkgs, flake-utils }: + flake-utils.lib.eachDefaultSystem (system: + let + pkgs = nixpkgs.legacyPackages.${system}; + in + { + devShells.default = pkgs.mkShell { + packages = with pkgs; [ + gnugrep + git + zola + ]; + }; + }); +}