all repos — website @ 4536e9e5dd826eb0e69c930312ba8f66e9c16175

My website

wip: read posts

Alan Pearce
commit

4536e9e5dd826eb0e69c930312ba8f66e9c16175

parent

ebb96f1a7f9828119bced5e562798a776f5849d4

1 file changed, 15 insertions(+), 5 deletions(-)

changed files
M flake.nixflake.nix
@@ -1,14 +1,19 @@
{ description = "My website, alanpearce.eu"; inputs.nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable"; - inputs.flake-utils.url = "github:numtide/flake-utils"; - inputs.flake-compat = { + inputs.utils.url = "github:numtide/flake-utils"; + inputs.compat = { url = "github:edolstra/flake-compat"; flake = false; }; + inputs.gomod2nix = { + url = "github:tweag/gomod2nix"; + inputs.nixpkgs.follows = "nixpkgs"; + inputs.flake-utils.follows = "utils"; + }; - outputs = { nixpkgs, flake-utils, ... }: - flake-utils.lib.eachDefaultSystem + outputs = { nixpkgs, utils, gomod2nix, ... }: + utils.lib.eachDefaultSystem (system: let pkgs = nixpkgs.legacyPackages.${system};
@@ -19,13 +24,18 @@ brotli
gzip zstd git + go ]; in rec { devShells = { default = pkgs.mkShell { packages = with pkgs; [ - bun + gopls + gotools + go-tools + gomod2nix.packages.${system}.default + gci flyctl ] ++ nativeBuildInputs; };