use long git hashes for docker tags
1 file changed, 4 insertions(+), 2 deletions(-)
changed files
M nix/scripts.nix → nix/scripts.nix
@@ -43,7 +43,9 @@ stream-fly | ${gzip}/bin/gzip --fast | ${skopeo}/bin/skopeo copy docker-archive:/dev/stdin "$@" '') (writeShellScriptBin "deploy" '' set -eu - push-to-registry docker://${image} - ${pkgs.flyctl}/bin/flyctl deploy + TAG=$(git rev-parse HEAD) + IMAGE=${image}:$TAG + push-to-registry docker://$IMAGE + ${pkgs.flyctl}/bin/flyctl deploy --image $IMAGE '') ]