all repos — website @ 3da735c4e72f8de390e5f4f0df63476cac43b6b1

My website

use long git hashes for docker tags

Alan Pearce
commit

3da735c4e72f8de390e5f4f0df63476cac43b6b1

parent

98cd9b3d285219fea65961f5cf551c42adfd22e9

1 file changed, 4 insertions(+), 2 deletions(-)

changed files
M nix/scripts.nixnix/scripts.nix
@@ -43,7 +43,9 @@ stream-fly | ${gzip}/bin/gzip --fast | ${skopeo}/bin/skopeo copy docker-archive:/dev/stdin "$@"
'') (writeShellScriptBin "deploy" '' set -eu - push-to-registry docker://${image} - ${pkgs.flyctl}/bin/flyctl deploy + TAG=$(git rev-parse HEAD) + IMAGE=${image}:$TAG + push-to-registry docker://$IMAGE + ${pkgs.flyctl}/bin/flyctl deploy --image $IMAGE '') ]