build with ko instead of nix
1 file changed, 2 insertions(+), 10 deletions(-)
changed files
M shell.nix → shell.nix
@@ -2,23 +2,15 @@ { pkgs ? ( let sources = import ./npins; in - import sources.nixpkgs { - overlays = [ - (import "${sources.gomod2nix}/overlay.nix") - ]; - } + import sources.nixpkgs { } ) }: let - goEnv = pkgs.mkGoEnv { pwd = ./.; }; inherit (import ./.) pre-commit-check; in pkgs.mkShell { inherit (pre-commit-check) shellHook; packages = with pkgs; [ - goEnv - gomod2nix - npins gopls gotools@@ -30,7 +22,7 @@ systemfd just modd - skopeo + ko flyctl nodePackages.vercel netlify-cli