server: configure with flags/envvars instead of toml
1 file changed, 2 insertions(+), 2 deletions(-)
changed files
M flake.nix → flake.nix
@@ -34,10 +34,10 @@ gomod2nix.packages.${system}.default gci flyctl (writeShellScriptBin "watch-builder" '' - ${pkgs.watchexec}/bin/watchexec -r -w flake.nix --shell fish 'direnv exec . watchexec -i server.go -i public -r go run ./cmd/build' + ${pkgs.watchexec}/bin/watchexec -r -w flake.nix --shell fish "direnv exec . watchexec -i server.go -i public -r go run ./cmd/build $@" '') (writeShellScriptBin "watch-server" '' - ${pkgs.watchexec}/bin/watchexec -r -w flake.nix --shell fish 'direnv exec . watchexec -r go run ./server.go' + ${pkgs.watchexec}/bin/watchexec -r -w flake.nix --shell fish "direnv exec . watchexec -r go run ./server.go $@" '') (writeShellScriptBin "check-licenses" '' ${pkgs.go-licenses}/bin/go-licenses check --include_tests ./... --disallowed_types=restricted,forbidden