about summary refs log tree commit diff stats
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix38
1 files changed, 2 insertions, 36 deletions
diff --git a/shell.nix b/shell.nix
index 2e85e8c..d2c4c45 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,37 +1,3 @@
-{ pkgs ? (
-    let
-      sources = import ./nix/sources.nix;
-    in
-    import sources.nixpkgs {
-      overlays = [
-        (import "${sources.gomod2nix}/overlay.nix")
-        (import ./nix/overlays/default.nix)
-      ];
-    }
-  )
-}:
+{ system ? builtins.currentSystem }:
 
-let
-  goEnv = pkgs.mkGoEnv { pwd = ./.; };
-  searchix = import ./default.nix {
-    inherit pkgs;
-  };
-in
-pkgs.mkShell {
-  packages = with pkgs; [
-    goEnv
-
-    brotli
-    bleve
-    wgo
-    gomod2nix
-    niv
-    nixpkgs-lint
-
-    bun
-  ];
-  shellHook = ''
-    ${searchix.pre-commit-check.shellHook}
-  '';
-  buildInputs = searchix.pre-commit-check.enabledPackages;
-}
+(builtins.getFlake (toString ./.)).devShells.${system}.default