about summary refs log tree commit diff stats
path: root/nix/dev-shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/dev-shell.nix')
-rw-r--r--nix/dev-shell.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/nix/dev-shell.nix b/nix/dev-shell.nix
new file mode 100644
index 0000000..0ba6b91
--- /dev/null
+++ b/nix/dev-shell.nix
@@ -0,0 +1,21 @@
+{ pre-commit-check
+, mkGoEnv
+, gomod2nix
+, mkShell
+, pkgs
+}:
+let
+  goEnv = mkGoEnv { pwd = ../.; };
+in
+mkShell {
+  packages = with pkgs;  [
+    goEnv
+
+    brotli
+    bleve
+    wgo
+    gomod2nix
+    nixpkgs-lint
+  ] ++ pre-commit-check.enabledPackages;
+  inherit (pre-commit-check) shellHook;
+}