about summary refs log tree commit diff stats
path: root/nix/dev-shell.nix
diff options
context:
space:
mode:
authorAlan Pearce2024-05-12 22:34:23 +0200
committerAlan Pearce2024-05-12 23:12:39 +0200
commit895a3b061bb4717955ffbceab3bf3c6ecebacd70 (patch)
treefed970785b9b0460693d07dcffae08283be90ce4 /nix/dev-shell.nix
parent7077a3748fa545e8dee83d4f3464c55b4b459183 (diff)
downloadsearchix-895a3b061bb4717955ffbceab3bf3c6ecebacd70.tar.lz
searchix-895a3b061bb4717955ffbceab3bf3c6ecebacd70.tar.zst
searchix-895a3b061bb4717955ffbceab3bf3c6ecebacd70.zip
build: switch to flakes
Diffstat (limited to 'nix/dev-shell.nix')
-rw-r--r--nix/dev-shell.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/nix/dev-shell.nix b/nix/dev-shell.nix
new file mode 100644
index 0000000..0ba6b91
--- /dev/null
+++ b/nix/dev-shell.nix
@@ -0,0 +1,21 @@
+{ pre-commit-check
+, mkGoEnv
+, gomod2nix
+, mkShell
+, pkgs
+}:
+let
+  goEnv = mkGoEnv { pwd = ../.; };
+in
+mkShell {
+  packages = with pkgs;  [
+    goEnv
+
+    brotli
+    bleve
+    wgo
+    gomod2nix
+    nixpkgs-lint
+  ] ++ pre-commit-check.enabledPackages;
+  inherit (pre-commit-check) shellHook;
+}