about summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix7
1 files changed, 5 insertions, 2 deletions
diff --git a/flake.nix b/flake.nix
index 48697c5..c0df6bf 100644
--- a/flake.nix
+++ b/flake.nix
@@ -41,11 +41,11 @@
           # This has no effect on other platforms.
           callPackage = pkgs.darwin.apple_sdk_11_0.callPackage or pkgs.callPackage;
         in
-        {
+        rec {
           packages.default = callPackage ./nix/package.nix {
             inherit (gomod2nix.legacyPackages.${system}) buildGoApplication;
-            css = simple-css;
             inherit self;
+            css = simple-css;
           };
           devShells.default = callPackage ./nix/dev-shell.nix {
             pre-commit-check = {
@@ -61,6 +61,9 @@
                 inherit pkgs;
               }
             );
+            buildVersion = pkgs.testers.testVersion {
+              package = packages.default;
+            };
           };
         })
     );