about summary refs log tree commit diff stats
path: root/nix/overlays/prettier-plugin-go-template/default.nix
diff options
context:
space:
mode:
authorAlan Pearce2024-05-04 12:38:32 +0200
committerAlan Pearce2024-05-04 14:49:08 +0200
commitdf2a55f82d5efeed8c59c5cf3b4e7381c97959b5 (patch)
treedb5fe1e53a4317fa8d35ef9596a082ac20fe70de /nix/overlays/prettier-plugin-go-template/default.nix
parent1fb64b09e2dba34784732a61cbebc119cd847803 (diff)
downloadsearchix-df2a55f82d5efeed8c59c5cf3b4e7381c97959b5.tar.lz
searchix-df2a55f82d5efeed8c59c5cf3b4e7381c97959b5.tar.zst
searchix-df2a55f82d5efeed8c59c5cf3b4e7381c97959b5.zip
chore: use prettier with plugin to format go templates
Diffstat (limited to 'nix/overlays/prettier-plugin-go-template/default.nix')
-rw-r--r--nix/overlays/prettier-plugin-go-template/default.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/nix/overlays/prettier-plugin-go-template/default.nix b/nix/overlays/prettier-plugin-go-template/default.nix
new file mode 100644
index 0000000..d9c0dae
--- /dev/null
+++ b/nix/overlays/prettier-plugin-go-template/default.nix
@@ -0,0 +1,17 @@
+# This file has been generated by node2nix 1.11.1. Do not edit!
+
+{pkgs ? import <nixpkgs> {
+    inherit system;
+  }, system ? builtins.currentSystem, nodejs ? pkgs."nodejs_18"}:
+
+let
+  nodeEnv = import ./node-env.nix {
+    inherit (pkgs) stdenv lib python2 runCommand writeTextFile writeShellScript;
+    inherit pkgs nodejs;
+    libtool = if pkgs.stdenv.isDarwin then pkgs.darwin.cctools else null;
+  };
+in
+import ./node-packages.nix {
+  inherit (pkgs) fetchurl nix-gitignore stdenv lib fetchgit;
+  inherit nodeEnv;
+}