Initial commit
1 file changed, 29 insertions(+), 0 deletions(-)
changed files
A flake.nix
@@ -0,0 +1,29 @@ +{ + description = "Emacs package containing modes for a set of file types"; + inputs.nixpkgs.url = "github:NixOS/nixpkgs"; + inputs.flake-utils.url = "github:numtide/flake-utils"; + inputs.flake-compat = { + url = "github:edolstra/flake-compat"; + flake = false; + }; + + outputs = + { self + , nixpkgs + , flake-utils + , flake-compat + , ... + }: + flake-utils.lib.eachDefaultSystem (system: + let + pkgs = nixpkgs.legacyPackages.${system}; + in + { + devShell = pkgs.mkShell { + buildInputs = with pkgs; + [ + emacsPackages.cask + ]; + }; + }); +}