summary refs log tree commit diff stats
path: root/user/settings/zsh.nix
diff options
context:
space:
mode:
Diffstat (limited to 'user/settings/zsh.nix')
-rw-r--r--user/settings/zsh.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/user/settings/zsh.nix b/user/settings/zsh.nix
index 0ff7f519..bb7b8974 100644
--- a/user/settings/zsh.nix
+++ b/user/settings/zsh.nix
@@ -8,7 +8,7 @@ let
   lsOptions =
     if stdenv.isDarwin
     then "-p"
-    else "-v --group-directories-first";
+    else "-v --group-directories-first --hyperlink=auto";
   lsIsoDate =
     if stdenv.isDarwin
     then ""
@@ -224,5 +224,5 @@ in
       );
   };
 
-  home.file."${zshrc}".onChange = "${pkgs.zsh}/bin/zsh -i -c 'autoload -Uz compinit && compinit && zcompile ${zshrc}'";
+  home.file."${zshrc}".onChange = "${pkgs.zsh}/bin/zsh -i -c 'autoload -Uz compinit && compinit && zcompile $HOME/${zshrc}'";
 }