summary refs log tree commit diff stats
path: root/user/settings/zsh.nix
diff options
context:
space:
mode:
Diffstat (limited to 'user/settings/zsh.nix')
-rw-r--r--user/settings/zsh.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/user/settings/zsh.nix b/user/settings/zsh.nix
index cda96e80..aec8ff50 100644
--- a/user/settings/zsh.nix
+++ b/user/settings/zsh.nix
@@ -42,7 +42,7 @@ in
     enable = true;
 
     enableAutosuggestions = true;
-    enableCompletion = true;
+    enableCompletion = false;
     defaultKeymap = "emacs";
 
     dotDir = ".config/zsh";
@@ -254,6 +254,8 @@ in
     '';
 
     initExtra = ''
+      autoload -Uz compinit
+      compinit -C
       typeset -T GHQ_ROOT ghq_root
       export GHQ_ROOT="$HOME/projects:$HOME/go/src:$HOME/quicklisp/local-projects"