summary refs log tree commit diff stats
path: root/user/settings/zsh.nix
diff options
context:
space:
mode:
Diffstat (limited to 'user/settings/zsh.nix')
-rw-r--r--user/settings/zsh.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/user/settings/zsh.nix b/user/settings/zsh.nix
index 209140ce..cd13391a 100644
--- a/user/settings/zsh.nix
+++ b/user/settings/zsh.nix
@@ -43,6 +43,10 @@ in
     up
   ];
 
+  home.sessionVariables = {
+    GHQ_ROOT = lib.mkDefault "${config.home.homeDirectory}/projects";
+  };
+
   programs.zsh = {
     enable = true;
 
@@ -227,7 +231,6 @@ in
     initExtra =
       ''
         typeset -T GHQ_ROOT ghq_root
-        export GHQ_ROOT="${config.home.homeDirectory}/projects"
 
         function hist-freq-subcommands () {
           fc -l -m "$1*" -10000 | cut -d' ' -f4- | sort | uniq -c | sort -gr | head -n100 | less