summary refs log tree commit diff stats
path: root/user/settings/zsh.nix
diff options
context:
space:
mode:
Diffstat (limited to 'user/settings/zsh.nix')
-rw-r--r--user/settings/zsh.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/user/settings/zsh.nix b/user/settings/zsh.nix
index ca13f4d0..b7232041 100644
--- a/user/settings/zsh.nix
+++ b/user/settings/zsh.nix
@@ -237,7 +237,11 @@ in
       source ${pkgs.fzf}/share/fzf/key-bindings.zsh
       source ${pkgs.fzf}/share/fzf/completion.zsh
 
-    '' + builtins.readFile ../zsh/zshrc;
+    '' + builtins.readFile ../zsh/zshrc + (
+      if stdenv.isDarwin
+      then builtins.readFile ../zsh/zshrc.darwin
+      else ""
+    );
   };
 
   home.file."${zshrc}".onChange =