summary refs log tree commit diff stats
path: root/user/settings/tabnine.nix
diff options
context:
space:
mode:
Diffstat (limited to 'user/settings/tabnine.nix')
-rw-r--r--user/settings/tabnine.nix29
1 files changed, 8 insertions, 21 deletions
diff --git a/user/settings/tabnine.nix b/user/settings/tabnine.nix
index 8018bcca..9fa586b0 100644
--- a/user/settings/tabnine.nix
+++ b/user/settings/tabnine.nix
@@ -1,8 +1,12 @@
-{ config, pkgs, ... }:
+{ ... }:
 
-let
-  cfg = {
-    config = {
+{
+  imports = [
+    ../modules/tabnine.nix
+  ];
+  programs.tabnine = {
+    enable = true;
+    lspConfig = {
       "language.typescript" = {
         command = "typescript-language-server";
         args = ["--stdio"];
@@ -37,21 +41,4 @@ let
       };
     };
   };
-  configFile = config:
-    pkgs.runCommand "TabNine.toml"
-      {
-         buildInputs = [ pkgs.remarshal ];
-         preferLocalBuild = true;
-         allowSubstitutes = false;
-      }
-      ''
-        remarshal -if json -of toml \
-          < ${pkgs.writeText "config.json" (builtins.toJSON cfg.config)} \
-          > $out
-      '';
-in
-{
-  xdg.configFile."TabNine/TabNine.toml" = {
-    source = configFile cfg.config;
-  };
 }