summary refs log tree commit diff stats
path: root/user/settings/ssh.nix
diff options
context:
space:
mode:
Diffstat (limited to 'user/settings/ssh.nix')
-rw-r--r--user/settings/ssh.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/user/settings/ssh.nix b/user/settings/ssh.nix
new file mode 100644
index 00000000..0c8300eb
--- /dev/null
+++ b/user/settings/ssh.nix
@@ -0,0 +1,12 @@
+{ config, lib, pkgs, ... }:
+
+{
+  programs.ssh = {
+    enable = true;
+    compression = true;
+    controlMaster = "auto";
+    controlPersist = "10m";
+    hashKnownHosts = true;
+    serverAliveInterval = 15;
+  };
+}