summary refs log tree commit diff stats
path: root/user/settings/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'user/settings/shell.nix')
-rw-r--r--user/settings/shell.nix12
1 files changed, 4 insertions, 8 deletions
diff --git a/user/settings/shell.nix b/user/settings/shell.nix
index 6542636a..62f68e14 100644
--- a/user/settings/shell.nix
+++ b/user/settings/shell.nix
@@ -118,14 +118,14 @@ in
 
       ho = "home-manager";
       hob = "home-manager build";
-      hos = "home-manager switch";
+      hos = "home-manager switch -b hm_bak_$(date +%Y%m%d%H%M)";
       hon = "home-manager news";
       hoh = "home-manager help";
       hop = "home-manager packages";
       hol = "home-manager generations";
       hox = "home-manager expire-generations '-30 days'";
 
-      nsh = "nix shell";
+      nsh = "nix-shell";
       nb = "nix build";
       nl = "nix log"; # shadows `coreutils.nl`, but I've never used that yet
       nr = "nix run";
@@ -135,6 +135,8 @@ in
       nfp = "nix flake prefetch";
       nfu = "nix flake update";
       nfl = "nix flake lock";
+      nfsh = "nix shell";
+      ndev = "nix develop";
       nlg = "nix-env --list-generations";
       snlg = "sudo nix-env --list-generations --profile /nix/var/nix/profiles/system";
       ngc = "nix-collect-garbage --delete-older-than 30d";
@@ -143,12 +145,6 @@ in
   };
   home.packages = with pkgs; [
     fzf
-    gh
-    ghq
-    delta
-    git
-    gitui
-    gitstatus
     up
   ];
 }