summary refs log tree commit diff stats
path: root/user/settings/rofi.nix
diff options
context:
space:
mode:
Diffstat (limited to 'user/settings/rofi.nix')
-rw-r--r--user/settings/rofi.nix12
1 files changed, 11 insertions, 1 deletions
diff --git a/user/settings/rofi.nix b/user/settings/rofi.nix
index b34af881..4e230866 100644
--- a/user/settings/rofi.nix
+++ b/user/settings/rofi.nix
@@ -1,4 +1,4 @@
-{ config, pkgs, ... }:
+{ config, lib, pkgs, ... }:
 
 {
   xdg.configFile."networkmanager-dmenu/config.ini".text = ''
@@ -9,6 +9,16 @@
     terminal = xst
     gui_if_available = false
   '';
+
+  nixpkgs.overlays = [
+    (self: super: {
+      rofi= super.rofi.overrideAttrs (oldAttrs: rec {
+        postInstall = ''
+          ln $out/bin/rofi $out/bin/dmenu
+        '';
+      });
+    })
+  ];
   programs.rofi = {
     enable = true;
     extraConfig = ''