summary refs log tree commit diff stats
path: root/user/settings/nix.nix
diff options
context:
space:
mode:
Diffstat (limited to 'user/settings/nix.nix')
-rw-r--r--user/settings/nix.nix6
1 files changed, 1 insertions, 5 deletions
diff --git a/user/settings/nix.nix b/user/settings/nix.nix
index 66c00daf..87db3d56 100644
--- a/user/settings/nix.nix
+++ b/user/settings/nix.nix
@@ -12,15 +12,11 @@ in
     enable = true;
     # needed for "standalone" home-manager, conflicts with module
     package = lib.mkDefault pkgs.nix;
-    settings = {
-      use-xdg-base-directories = true;
-    };
   };
 
   home.packages = with pkgs; [
     cached-nix-shell
     nil
-    npins
     nix-prefetch-scripts
     nix-init
     nix-update
@@ -33,7 +29,7 @@ in
   ];
   xdg.configFile."nix-init/config.toml".source = toml.generate "config.toml" {
     maintainers = [ "alanpearce" ];
-    nixpkgs = "<nixpkgs>";
+    nixpkgs = "builtins.getFlake \"nixpkgs\"";
   };
   programs.emacs.extraPackages = epkgs: (with epkgs; [
     nix-mode