summary refs log tree commit diff stats
path: root/user/settings/nix.nix
diff options
context:
space:
mode:
Diffstat (limited to 'user/settings/nix.nix')
-rw-r--r--user/settings/nix.nix12
1 files changed, 6 insertions, 6 deletions
diff --git a/user/settings/nix.nix b/user/settings/nix.nix
index e0fb3d3e..66c00daf 100644
--- a/user/settings/nix.nix
+++ b/user/settings/nix.nix
@@ -1,25 +1,26 @@
 { config
 , pkgs
+, lib
 , ...
 }:
 let
   toml = pkgs.formats.toml { };
 in
 {
-  imports = [
-    ../../pin.nix
-  ];
   nixpkgs.config = import ../config.nix;
   nix = {
     enable = true;
-    package = pkgs.nix;
+    # needed for "standalone" home-manager, conflicts with module
+    package = lib.mkDefault pkgs.nix;
     settings = {
       use-xdg-base-directories = true;
     };
   };
 
   home.packages = with pkgs; [
+    cached-nix-shell
     nil
+    npins
     nix-prefetch-scripts
     nix-init
     nix-update
@@ -29,11 +30,10 @@ in
     nixpkgs-lint
     nixpkgs-review
     nix-output-monitor
-    cachix
   ];
   xdg.configFile."nix-init/config.toml".source = toml.generate "config.toml" {
     maintainers = [ "alanpearce" ];
-    nixpkgs = "builtins.getFlake \"nixpkgs\"";
+    nixpkgs = "<nixpkgs>";
   };
   programs.emacs.extraPackages = epkgs: (with epkgs; [
     nix-mode