summary refs log tree commit diff stats
path: root/user/settings/gaming.nix
diff options
context:
space:
mode:
Diffstat (limited to 'user/settings/gaming.nix')
-rw-r--r--user/settings/gaming.nix45
1 files changed, 45 insertions, 0 deletions
diff --git a/user/settings/gaming.nix b/user/settings/gaming.nix
new file mode 100644
index 00000000..022846ca
--- /dev/null
+++ b/user/settings/gaming.nix
@@ -0,0 +1,45 @@
+{ config, pkgs, ... }:
+
+{
+  home.packages = with pkgs; [
+    unstable.steam
+    (
+      unstable.winePackages.unstable.override {
+        pngSupport = true;
+        jpegSupport = true;
+        tiffSupport = true;
+        gettextSupport = true;
+        fontconfigSupport = true;
+        alsaSupport = true;
+        gtkSupport = true;
+        openglSupport = true;
+        tlsSupport = true;
+        gstreamerSupport = true;
+        cupsSupport = true;
+        colorManagementSupport = true;
+        dbusSupport = true;
+        mpg123Support = true;
+        openalSupport = true;
+        openclSupport = true;
+        cairoSupport = true;
+        odbcSupport = true;
+        netapiSupport = true;
+        cursesSupport = true;
+        vaSupport = true;
+        pcapSupport = true;
+        v4lSupport = true;
+        saneSupport = true;
+        gsmSupport = true;
+        gphoto2Support = true;
+        ldapSupport = true;
+        pulseaudioSupport = true;
+        udevSupport = true;
+        xineramaSupport = true;
+        xmlSupport = true;
+        vulkanSupport = true;
+        sdlSupport = true;
+      }
+    )
+    unstable.lutris
+  ];
+}