summary refs log tree commit diff stats
path: root/user/settings/fish.nix
diff options
context:
space:
mode:
Diffstat (limited to 'user/settings/fish.nix')
-rw-r--r--user/settings/fish.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/user/settings/fish.nix b/user/settings/fish.nix
index b548c71c..e9e7de82 100644
--- a/user/settings/fish.nix
+++ b/user/settings/fish.nix
@@ -36,6 +36,12 @@
     interactiveShellInit = ''
       bind \es __ghq_repository_search
     '';
+    shellInit = ''
+      if test -n $KITTY_INSTALLATION_DIR
+      then
+        set -x KITTY_SHELL_INTEGRATION no-cursor
+      fi
+    '';
     functions = {
       ds = "du -hd1 $argv[1] | sort -h";
     };