summary refs log tree commit diff stats
path: root/user/settings/fish.nix
diff options
context:
space:
mode:
authorAlan Pearce2023-08-22 19:10:12 +0200
committerAlan Pearce2023-08-22 19:10:12 +0200
commitf8f5398d96b34adb178b9b73ee8228e78eddd329 (patch)
tree5f64f2d37ada0e7e96a74f35b91b13b7dc626171 /user/settings/fish.nix
parent4a22fe0cf6b7c54d67dbf7c45d82fb8d7f330bbf (diff)
downloadnixfiles-f8f5398d96b34adb178b9b73ee8228e78eddd329.tar.lz
nixfiles-f8f5398d96b34adb178b9b73ee8228e78eddd329.tar.zst
nixfiles-f8f5398d96b34adb178b9b73ee8228e78eddd329.zip
Remove zsh config
Diffstat (limited to 'user/settings/fish.nix')
-rw-r--r--user/settings/fish.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/user/settings/fish.nix b/user/settings/fish.nix
index b548c71c..e9e7de82 100644
--- a/user/settings/fish.nix
+++ b/user/settings/fish.nix
@@ -36,6 +36,12 @@
     interactiveShellInit = ''
       bind \es __ghq_repository_search
     '';
+    shellInit = ''
+      if test -n $KITTY_INSTALLATION_DIR
+      then
+        set -x KITTY_SHELL_INTEGRATION no-cursor
+      fi
+    '';
     functions = {
       ds = "du -hd1 $argv[1] | sort -h";
     };