summary refs log tree commit diff stats
path: root/user/settings/fish.nix
diff options
context:
space:
mode:
Diffstat (limited to 'user/settings/fish.nix')
-rw-r--r--user/settings/fish.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/user/settings/fish.nix b/user/settings/fish.nix
index 5af965cd..6ddbe120 100644
--- a/user/settings/fish.nix
+++ b/user/settings/fish.nix
@@ -27,5 +27,12 @@
     interactiveShellInit = ''
       bind \es __ghq_repository_search
     '';
+    functions = {
+      ds = "du -hd1 $argv[1] | sort -h";
+    };
+  };
+  xdg.configFile."fish/functions" = {
+    recursive = true;
+    source = ./fish/functions;
   };
 }