summary refs log tree commit diff stats
path: root/user/settings/fish.nix
diff options
context:
space:
mode:
authorAlan Pearce2023-08-20 06:52:48 +0200
committerAlan Pearce2023-08-20 06:52:48 +0200
commita1e7e0bc3e2cf040d24580ecfe3f73899b358aa1 (patch)
tree5bd05f75c23c3d1e069849c2e8f858acfbb90883 /user/settings/fish.nix
parenta0c89188898a79599f83a83297946631fb78bf9b (diff)
downloadnixfiles-a1e7e0bc3e2cf040d24580ecfe3f73899b358aa1.tar.lz
nixfiles-a1e7e0bc3e2cf040d24580ecfe3f73899b358aa1.tar.zst
nixfiles-a1e7e0bc3e2cf040d24580ecfe3f73899b358aa1.zip
fish: port functions and more aliases
Diffstat (limited to 'user/settings/fish.nix')
-rw-r--r--user/settings/fish.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/user/settings/fish.nix b/user/settings/fish.nix
index 5af965cd..6ddbe120 100644
--- a/user/settings/fish.nix
+++ b/user/settings/fish.nix
@@ -27,5 +27,12 @@
     interactiveShellInit = ''
       bind \es __ghq_repository_search
     '';
+    functions = {
+      ds = "du -hd1 $argv[1] | sort -h";
+    };
+  };
+  xdg.configFile."fish/functions" = {
+    recursive = true;
+    source = ./fish/functions;
   };
 }