summary refs log tree commit diff stats
path: root/user/settings/fish.nix
diff options
context:
space:
mode:
Diffstat (limited to 'user/settings/fish.nix')
-rw-r--r--user/settings/fish.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/user/settings/fish.nix b/user/settings/fish.nix
index 7dee70b4..4bee970f 100644
--- a/user/settings/fish.nix
+++ b/user/settings/fish.nix
@@ -42,6 +42,10 @@
         set -x KITTY_SHELL_INTEGRATION no-cursor
       end
     '';
+    shellAliases = {
+      hist-freq-lines = "history | sort | uniq -c | sort -gr | head -n100 | less";
+      hist-freq-commands = "history | cut -d' ' -f 1 | sort | uniq -c | sort -gr | head -n100 | less";
+    };
     functions = {
       ds = "du -hd1 $argv[1] | sort -h";
     };