summary refs log tree commit diff stats
path: root/user/settings/fish.nix
diff options
context:
space:
mode:
Diffstat (limited to 'user/settings/fish.nix')
-rw-r--r--user/settings/fish.nix30
1 files changed, 3 insertions, 27 deletions
diff --git a/user/settings/fish.nix b/user/settings/fish.nix
index 480c9ade..574c74d3 100644
--- a/user/settings/fish.nix
+++ b/user/settings/fish.nix
@@ -2,6 +2,7 @@
 , lib
 , ...
 }: {
+  home.shell.enableFishIntegration = true;
   programs.fish = {
     enable = true;
     plugins =
@@ -11,15 +12,7 @@
       with pkgs.fishPlugins; [
         (fromNixpkgs fzf-fish)
         (fromNixpkgs autopair)
-        {
-          name = "fishplugin-hydro";
-          src = pkgs.fetchFromGitHub {
-            owner = "jorgebucaran";
-            repo = "hydro";
-            hash = "sha256-QYq4sU41/iKvDUczWLYRGqDQpVASF/+6brJJ8IxypjE=";
-            rev = "9c93b89573bd722f766f2190a862ae55e728f6ba";
-          };
-        }
+        (fromNixpkgs hydro)
         {
           name = "ghq";
           src = pkgs.fetchFromGitHub {
@@ -59,24 +52,7 @@
     functions = {
       ds = "du -hd1 $argv[1] | sort -h";
       last_history_item = "echo $history[1]";
-    } // (lib.attrsets.optionalAttrs pkgs.stdenv.isLinux {
-      open = ''
-        argparse h/help a/application -- $argv
-        or return
-
-        if set -ql _flag_help
-           echo "open [-h|--help] [-a application] [arguments...]"
-           return 1
-        end
-
-        if set -ql _flag_application
-           # TODO: support reverse-domain- named files (e.g. org.kde.kate.desktop)
-           ${pkgs.gtk3}/bin/gtk-launch $argv[1]
-        else
-          xdg-open $argv
-        end
-      '';
-    });
+    };
   };
   xdg.configFile."fish/completions" = {
     recursive = true;