summary refs log tree commit diff stats
path: root/user/settings/emacs.nix
diff options
context:
space:
mode:
Diffstat (limited to 'user/settings/emacs.nix')
-rw-r--r--user/settings/emacs.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/user/settings/emacs.nix b/user/settings/emacs.nix
index ceeff4b7..6d0f7e1c 100644
--- a/user/settings/emacs.nix
+++ b/user/settings/emacs.nix
@@ -161,6 +161,10 @@ in
     extraConfig = ''
       (with-eval-after-load 'editorconfig
         (setq editorconfig-exec-path "${pkgs.editorconfig-core-c}/bin/editorconfig"))
+      (with-eval-after-load 'company-tabnine
+        (advice-add 'company-tabnine--executable-path :around
+          (lambda (original-function &rest args)
+            "${pkgs.tabnine}/bin/TabNine")))
     '' + lib.optionalString stdenv.isDarwin ''
       (with-eval-after-load 'files
         (setq insert-directory-program "${pkgs.coreutils-prefixed}/bin/gls"))