summary refs log tree commit diff stats
path: root/user/settings/emacs.nix
diff options
context:
space:
mode:
Diffstat (limited to 'user/settings/emacs.nix')
-rw-r--r--user/settings/emacs.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/user/settings/emacs.nix b/user/settings/emacs.nix
index 71f2401f..722a7a6d 100644
--- a/user/settings/emacs.nix
+++ b/user/settings/emacs.nix
@@ -155,6 +155,15 @@ in
         ws-butler
         which-key
       ]);
+    overrides = self: super: rec {
+      apheleia = self.melpaPackages.apheleia.overrideAttrs
+        (old: {
+          patchPhase = ''
+            substituteInPlace apheleia-formatters.el \
+              --replace-fail '"prettier"' '"prettierd"'
+          '';
+        });
+    };
     extraConfig = ''
       (with-eval-after-load 'editorconfig
         (setq editorconfig-exec-path "${pkgs.editorconfig-core-c}/bin/editorconfig"))