summary refs log tree commit diff stats
path: root/user/settings/emacs.nix
diff options
context:
space:
mode:
Diffstat (limited to 'user/settings/emacs.nix')
-rw-r--r--user/settings/emacs.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/user/settings/emacs.nix b/user/settings/emacs.nix
index b44409ec..ea042814 100644
--- a/user/settings/emacs.nix
+++ b/user/settings/emacs.nix
@@ -47,7 +47,7 @@ in
 
   programs.emacs = {
     enable = true;
-    package = lib.mkDefault (pkgs.emacs.override { withGTK3 = true; });
+    package = lib.mkDefault (pkgs.commercial-emacs);
     overrides = self: super: (
       {
         consult-ghq = super.consult-ghq.overrideAttrs
@@ -97,7 +97,6 @@ in
         ace-link
         apheleia
         avy
-        benchmark-init
         capf-autosuggest
         clojure-mode
         company
@@ -182,8 +181,9 @@ in
     extraConfig = ''
       (with-eval-after-load 'editorconfig
         (setq editorconfig-exec-path "${pkgs.editorconfig-core-c}/bin/editorconfig"))
-      (setq native-compile-target-directory "${nativeCompileDirectory}")
-      (add-to-list 'native-comp-eln-load-path "${nativeCompileDirectory}" :append)
+      (when (featurep 'native-compile)
+        (setq native-compile-target-directory "${nativeCompileDirectory}")
+        (add-to-list 'native-comp-eln-load-path "${nativeCompileDirectory}" :append))
     '' + lib.optionalString stdenv.isDarwin ''
       (with-eval-after-load 'files
         (setq insert-directory-program "${pkgs.coreutils-prefixed}/bin/gls"))