summary refs log tree commit diff stats
path: root/user/settings/emacs.nix
diff options
context:
space:
mode:
Diffstat (limited to 'user/settings/emacs.nix')
-rw-r--r--user/settings/emacs.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/user/settings/emacs.nix b/user/settings/emacs.nix
index befc302d..db0c3357 100644
--- a/user/settings/emacs.nix
+++ b/user/settings/emacs.nix
@@ -7,7 +7,7 @@ let
   inherit (pkgs) stdenv;
 
   darwinPath = pkgs.runCommandLocal "path_helper " { } ''
-    eval $(/usr/libexec/path_helper -s)
+    eval $(/usr/libexec/path_helper)
     echo -n $PATH > $out
   '';
 
@@ -167,7 +167,7 @@ in
         (setq insert-directory-program "${pkgs.coreutils-prefixed}/bin/gls"))
       (with-eval-after-load 'dired
         (setq dired-use-ls-dired t))
-      (setq exec-path (parse-colon-path (setenv "PATH" "${pkgs.lib.readFile darwinPath}")))
+      (setq exec-path (parse-colon-path (setenv "PATH" "${pkgs.clang}/bin:${pkgs.gcc}/bin:${pkgs.lib.readFile darwinPath}")))
     '';
   };
   home.packages = [