summary refs log tree commit diff stats
path: root/user/settings/emacs.nix
diff options
context:
space:
mode:
Diffstat (limited to 'user/settings/emacs.nix')
-rw-r--r--user/settings/emacs.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/user/settings/emacs.nix b/user/settings/emacs.nix
index e6114e2a..b5470c96 100644
--- a/user/settings/emacs.nix
+++ b/user/settings/emacs.nix
@@ -159,6 +159,7 @@ in
         treesit-grammars.with-all-grammars
         treesit-auto
         try
+        ultra-scroll
         vc-msg
         vertico
         vertico-prescient
@@ -169,6 +170,23 @@ in
         yasnippet-capf
       ]);
     overrides = self: super: {
+      ultra-scroll = self.melpaBuild rec {
+        pname = "ultra-scroll";
+        version = "0.3.1";
+
+        src = pkgs.fetchFromGitHub {
+          owner = "jdtsmith";
+          repo = pname;
+          rev = "2e3b9997ae1a469e878feaa0af23a23685a0fbed";
+          hash = "sha256-9+3T5tXPRuRtENt/Rr0Ss3LZJlTOwpGePbREqofN2j0=";
+        };
+
+        meta = {
+          homepage = "https://github.com/jdtsmith/ultra-scroll";
+          description = "scroll emacs like lightning";
+          license = pkgs.lib.licenses.gpl3;
+        };
+      };
       apheleia = self.melpaPackages.apheleia.overrideAttrs
         (old: {
           patchPhase = ''