summary refs log tree commit diff stats
path: root/user/settings/development/web.nix
diff options
context:
space:
mode:
Diffstat (limited to 'user/settings/development/web.nix')
-rw-r--r--user/settings/development/web.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/user/settings/development/web.nix b/user/settings/development/web.nix
index f1f45878..64502198 100644
--- a/user/settings/development/web.nix
+++ b/user/settings/development/web.nix
@@ -12,4 +12,17 @@
     ++ [
       pkgs.nodePackages.stylelint
     ];
+  programs.emacs.extraPackages = epkgs: (with epkgs; [
+    caddyfile-mode
+    company-web
+    emmet-mode
+    nginx-mode
+    restclient
+    scss-mode
+    web-mode
+  ]);
+  programs.neovim.plugins = with pkgs.vimPlugins; [
+    coc-css
+    coc-html
+  ];
 }