summary refs log tree commit diff stats
path: root/user/settings/development/javascript.nix
diff options
context:
space:
mode:
Diffstat (limited to 'user/settings/development/javascript.nix')
-rw-r--r--user/settings/development/javascript.nix41
1 files changed, 21 insertions, 20 deletions
diff --git a/user/settings/development/javascript.nix b/user/settings/development/javascript.nix
index 692995e7..6421c8b3 100644
--- a/user/settings/development/javascript.nix
+++ b/user/settings/development/javascript.nix
@@ -1,10 +1,11 @@
-{
-  config,
-  pkgs,
-  ...
-}: let
+{ config
+, pkgs
+, ...
+}:
+let
   nodejs = pkgs.nodejs-18_x;
-in {
+in
+{
   nixpkgs.overlays = [
     (self: super: {
       node2nixPackages = super.callPackage ../../packages/node2nix {
@@ -14,21 +15,21 @@ in {
   ];
   home.packages =
     (with pkgs;
-      [
-        nodejs
+    [
+      nodejs
+    ]
+    ++ (
+      if stdenv.isDarwin
+      then [
+      ]
+      else [
+        # npm install may use any of these
+        binutils
+        gnumake
+        gcc
+        python2
       ]
-      ++ (
-        if stdenv.isDarwin
-        then [
-        ]
-        else [
-          # npm install may use any of these
-          binutils
-          gnumake
-          gcc
-          python2
-        ]
-      ))
+    ))
     ++ (with pkgs.nodePackages; [
       node2nix
       nodemon