summary refs log tree commit diff stats
path: root/user/settings/development/golang.nix
diff options
context:
space:
mode:
Diffstat (limited to 'user/settings/development/golang.nix')
-rw-r--r--user/settings/development/golang.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/user/settings/development/golang.nix b/user/settings/development/golang.nix
new file mode 100644
index 00000000..ccacb580
--- /dev/null
+++ b/user/settings/development/golang.nix
@@ -0,0 +1,13 @@
+{ pkgs, ... }: {
+  home.packages = with pkgs; [
+    go
+    gopls
+    gotools
+  ];
+  programs.emacs.extraPackages = epkgs: (with epkgs; [
+    go-eldoc
+  ]);
+  programs.neovim.plugins = with pkgs.vimPlugins; [
+    coc-go
+  ];
+}