summary refs log tree commit diff stats
path: root/user/settings/development/golang.nix
diff options
context:
space:
mode:
Diffstat (limited to 'user/settings/development/golang.nix')
-rw-r--r--user/settings/development/golang.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/user/settings/development/golang.nix b/user/settings/development/golang.nix
index 39baf910..7fe5ad1e 100644
--- a/user/settings/development/golang.nix
+++ b/user/settings/development/golang.nix
@@ -15,6 +15,7 @@
   home.sessionPath = [
     "$HOME/go/bin"
   ];
+  home.sessionVariables.GOTOOLCHAIN = "local"; # use installed go tools
   programs.emacs.extraPackages = epkgs: (with epkgs; [
     go-eldoc
     go-tag
@@ -23,4 +24,8 @@
   programs.neovim.plugins = with pkgs.vimPlugins; [
     coc-go
   ];
+  programs.fish.shellAbbrs = {
+    gmt = "go mod tidy";
+    gmd = "go mod download";
+  };
 }