summary refs log tree commit diff stats
path: root/user/settings/darwin.nix
diff options
context:
space:
mode:
Diffstat (limited to 'user/settings/darwin.nix')
-rw-r--r--user/settings/darwin.nix18
1 files changed, 3 insertions, 15 deletions
diff --git a/user/settings/darwin.nix b/user/settings/darwin.nix
index e894bebd..f445e5cb 100644
--- a/user/settings/darwin.nix
+++ b/user/settings/darwin.nix
@@ -109,8 +109,8 @@
   };
 
   home.shellAliases = {
-    rb = "darwin-rebuild";
-    rbs = "darwin-rebuild switch";
+    rb = "nh os";
+    rbs = "nh os switch";
 
     dig = "dig +noall +answer";
 
@@ -118,19 +118,7 @@
   };
 
   programs.ssh.extraConfig = ''
-    IdentityAgent "~/.strongbox/agent.sock"
-  '';
-
-  home.activation.linkStrongboxSSHAgentSocket = lib.hm.dag.entryAfter [ "writeBoundary" ] ''
-    if [[ ! -d ~/.strongbox ]]
-    then
-      $DRY_RUN_CMD mkdir ~/.strongbox
-    fi
-    if [[ ! -S ~/.strongbox/agent.sock ]]
-    then
-      $DRY_RUN_CMD ln -s $VERBOSE_ARG \
-        ~/Library/Group\ Containers/group.strongbox.mac.mcguill/agent.sock ~/.strongbox/agent.sock
-    fi
+    IdentityAgent ~/Library/Containers/com.maxgoedjen.Secretive.SecretAgent/Data/socket.ssh
   '';
 
   # Use GPG from  GPGTools