summary refs log tree commit diff stats
path: root/user/settings/base.nix
diff options
context:
space:
mode:
Diffstat (limited to 'user/settings/base.nix')
-rw-r--r--user/settings/base.nix9
1 files changed, 5 insertions, 4 deletions
diff --git a/user/settings/base.nix b/user/settings/base.nix
index d0c01b87..05ad7089 100644
--- a/user/settings/base.nix
+++ b/user/settings/base.nix
@@ -29,7 +29,6 @@ args@{ config
       ABDUCO_SOCKET_DIR = "${state}/abduco";
       GNUPGHOME = "${data}/gnupg";
       SOLARGRAPH_CACHE = "${cache}/solargraph";
-      ASPELL_CONF = "per-conf ${conf}/aspell/aspell.conf; personal ${conf}/aspell/en.pws; repl ${conf}/aspell/en.prepl; dict-dir ${config.home.profileDirectory}/lib/aspell";
       ELECTRUMDIR = "${data}/electrum";
       DOCKER_CONFIG = "${conf}/docker";
       npm_config_userconfig = "${conf}/npm/config";
@@ -102,9 +101,11 @@ args@{ config
       abduco
       dvtm
       walk
-      (aspellWithDicts (d: [ d.en d.en-computers d.en-science d.de ]))
-    ]
-    ++ (
+      nuspell
+    ] ++ (with pkgs.hunspellDicts; [
+      en-gb-large
+      de-de
+    ]) ++ (
       if !stdenv.isDarwin
       then [
         file