summary refs log tree commit diff stats
path: root/user/settings/base.nix
diff options
context:
space:
mode:
authorAlan Pearce2024-05-18 14:58:50 +0200
committerAlan Pearce2024-05-18 19:04:50 +0200
commitb2ad0c7cb46cc809614ecaa45b1413f225309e54 (patch)
treece9744267058d34a845282db60ace0420cbead87 /user/settings/base.nix
parent31db71eacbb7977faf8ae5fd5886d72f4251ce63 (diff)
downloadnixfiles-b2ad0c7cb46cc809614ecaa45b1413f225309e54.tar.lz
nixfiles-b2ad0c7cb46cc809614ecaa45b1413f225309e54.tar.zst
nixfiles-b2ad0c7cb46cc809614ecaa45b1413f225309e54.zip
user: fix jinx-mode missing dictionaries when launched from DE
remove aspell, use nuspell/hunspell instead. They already know where
to look for dictionaries.
Diffstat (limited to 'user/settings/base.nix')
-rw-r--r--user/settings/base.nix9
1 files changed, 5 insertions, 4 deletions
diff --git a/user/settings/base.nix b/user/settings/base.nix
index d0c01b87..05ad7089 100644
--- a/user/settings/base.nix
+++ b/user/settings/base.nix
@@ -29,7 +29,6 @@ args@{ config
       ABDUCO_SOCKET_DIR = "${state}/abduco";
       GNUPGHOME = "${data}/gnupg";
       SOLARGRAPH_CACHE = "${cache}/solargraph";
-      ASPELL_CONF = "per-conf ${conf}/aspell/aspell.conf; personal ${conf}/aspell/en.pws; repl ${conf}/aspell/en.prepl; dict-dir ${config.home.profileDirectory}/lib/aspell";
       ELECTRUMDIR = "${data}/electrum";
       DOCKER_CONFIG = "${conf}/docker";
       npm_config_userconfig = "${conf}/npm/config";
@@ -102,9 +101,11 @@ args@{ config
       abduco
       dvtm
       walk
-      (aspellWithDicts (d: [ d.en d.en-computers d.en-science d.de ]))
-    ]
-    ++ (
+      nuspell
+    ] ++ (with pkgs.hunspellDicts; [
+      en-gb-large
+      de-de
+    ]) ++ (
       if !stdenv.isDarwin
       then [
         file