summary refs log tree commit diff stats
path: root/user/settings/base.nix
diff options
context:
space:
mode:
Diffstat (limited to 'user/settings/base.nix')
-rw-r--r--user/settings/base.nix13
1 files changed, 6 insertions, 7 deletions
diff --git a/user/settings/base.nix b/user/settings/base.nix
index d0c01b87..52cb14ac 100644
--- a/user/settings/base.nix
+++ b/user/settings/base.nix
@@ -25,11 +25,8 @@ args@{ config
     in
     {
       EMAIL = "alan@alanpearce.eu";
-      MANPAGER = "bat -l man -p";
       ABDUCO_SOCKET_DIR = "${state}/abduco";
-      GNUPGHOME = "${data}/gnupg";
       SOLARGRAPH_CACHE = "${cache}/solargraph";
-      ASPELL_CONF = "per-conf ${conf}/aspell/aspell.conf; personal ${conf}/aspell/en.pws; repl ${conf}/aspell/en.prepl; dict-dir ${config.home.profileDirectory}/lib/aspell";
       ELECTRUMDIR = "${data}/electrum";
       DOCKER_CONFIG = "${conf}/docker";
       npm_config_userconfig = "${conf}/npm/config";
@@ -75,7 +72,7 @@ args@{ config
     ];
     config = {
       theme = "ansi";
-      style = "header-filename,header-filesize,grid,rule";
+      style = "header-filename,header-filesize,rule";
     };
   };
   programs.nix-index-database.comma.enable = true;
@@ -102,9 +99,11 @@ args@{ config
       abduco
       dvtm
       walk
-      (aspellWithDicts (d: [ d.en d.en-computers d.en-science d.de ]))
-    ]
-    ++ (
+      nuspell
+    ] ++ (with pkgs.hunspellDicts; [
+      en-gb-large
+      de-de
+    ]) ++ (
       if !stdenv.isDarwin
       then [
         file