summary refs log tree commit diff stats
path: root/user/packages/interactively/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'user/packages/interactively/default.nix')
-rw-r--r--user/packages/interactively/default.nix35
1 files changed, 35 insertions, 0 deletions
diff --git a/user/packages/interactively/default.nix b/user/packages/interactively/default.nix
new file mode 100644
index 00000000..dc7885f5
--- /dev/null
+++ b/user/packages/interactively/default.nix
@@ -0,0 +1,35 @@
+{ stdenv
+, fetchFromGitHub
+, coreutils
+, fzf
+}:
+
+stdenv.mkDerivation {
+  pname = "interactively";
+  version = "unstable-2023-04-19";
+
+  src = fetchFromGitHub {
+    owner = "bigH";
+    repo = "interactively";
+    rev = "c09f14b4e572053eb8e1e8dfb0b74ee66a66c07f";
+    hash = "sha256-HFCTX9lHiLymSyJMiFYSKG+7TCSb9YpmtC+I7Jf+zUg=";
+  };
+
+  fixupPhase = ''
+    patchShebangs bin/interactively
+    substituteInPlace bin/interactively \
+      --replace fzf ${fzf}/bin/fzf \
+      --replace tac ${coreutils}/bin/tac
+  '';
+
+  installPhase = ''
+    mkdir -p $out/bin
+    cp bin/interactively $out/bin/
+    chmod +x $out/bin/interactively
+  '';
+
+  meta = {
+    description = "";
+    homepage = "https://github.com/bigH/interactively";
+  };
+}