summary refs log tree commit diff stats
path: root/user/modules/zsh.nix
diff options
context:
space:
mode:
Diffstat (limited to 'user/modules/zsh.nix')
-rw-r--r--user/modules/zsh.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/user/modules/zsh.nix b/user/modules/zsh.nix
new file mode 100644
index 00000000..28e82293
--- /dev/null
+++ b/user/modules/zsh.nix
@@ -0,0 +1,12 @@
+{ config, pkgs, ... }:
+
+{
+  home.file = {
+    ".rm_recycle_home".text = ""; # use trash automatically in home directory
+    ".zshenv".text = builtins.readFile ../zsh/.zshenv;
+  };
+  xdg.configFile.zsh = {
+    recursive = true;
+    source = ../zsh/.config/zsh;
+  };
+}