summary refs log tree commit diff stats
path: root/user/modules/zsh.nix
diff options
context:
space:
mode:
Diffstat (limited to 'user/modules/zsh.nix')
-rw-r--r--user/modules/zsh.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/user/modules/zsh.nix b/user/modules/zsh.nix
index 9ace6f75..89faa1a8 100644
--- a/user/modules/zsh.nix
+++ b/user/modules/zsh.nix
@@ -17,6 +17,17 @@
     source = ../zsh/.config/zsh;
   };
 
+  home.file.".zplugin/bin" = {
+    recursive = true;
+    source = pkgs.fetchFromGitHub {
+      owner = "zdharma";
+      repo = "zplugin";
+      rev = "028b1e1d6d3eae204b499c7f815f4eeeb5051517";
+      sha256 = "1ynh323905iia3gwi9qghbywp94x306nna1yqk37frj5g7kg90fa";
+    };
+    onChange = "${pkgs.zsh}/bin/zsh -c 'zcompile $HOME/.zplugin/bin/zplugin.zsh'";
+  };
+
   programs.zsh = {
     enable = true;