summary refs log tree commit diff stats
path: root/user/modules/tabnine.nix
diff options
context:
space:
mode:
Diffstat (limited to 'user/modules/tabnine.nix')
-rw-r--r--user/modules/tabnine.nix57
1 files changed, 0 insertions, 57 deletions
diff --git a/user/modules/tabnine.nix b/user/modules/tabnine.nix
deleted file mode 100644
index 8018bcca..00000000
--- a/user/modules/tabnine.nix
+++ /dev/null
@@ -1,57 +0,0 @@
-{ config, pkgs, ... }:
-
-let
-  cfg = {
-    config = {
-      "language.typescript" = {
-        command = "typescript-language-server";
-        args = ["--stdio"];
-      };
-      "language.javascript" = {
-        command = "javascript-typescript-stdio";
-        args = ["--stdio"];
-      };
-      "language.css" = {
-        command = "css-languageserver";
-        args = ["--stdio"];
-      };
-      "language.scss" = {
-        command = "css-languageserver";
-        args = ["--stdio"];
-      };
-      "language.html" = {
-        command = "html-languageserver";
-        args = ["--stdio"];
-      };
-      "language.dockerfile" = {
-        command = "docker-langserver";
-        args = ["--stdio"];
-      };
-      "language.yaml" = {
-        command = "yaml-language-server";
-        args = ["--stdio"];
-      };
-      "language.haskell" = {
-        command = "hie";
-        args = ["--stdio"];
-      };
-    };
-  };
-  configFile = config:
-    pkgs.runCommand "TabNine.toml"
-      {
-         buildInputs = [ pkgs.remarshal ];
-         preferLocalBuild = true;
-         allowSubstitutes = false;
-      }
-      ''
-        remarshal -if json -of toml \
-          < ${pkgs.writeText "config.json" (builtins.toJSON cfg.config)} \
-          > $out
-      '';
-in
-{
-  xdg.configFile."TabNine/TabNine.toml" = {
-    source = configFile cfg.config;
-  };
-}